Moduł ESP8266 nie działa

+1 głos
355 wizyt
pytanie zadane 28 kwietnia 2016 przez użytkownika bulbulator (3)

Chciałem wgrać na mój moduł oprogramowanie ale program którego używał elektroprzewodnik nie może się połączyć (przekracza liczbę prób połączenia się). Próbowałem z innym programem (ESP FLASH Download TOOL) który niby coś wgrał to znaczy mrugała chwile dioda RX na module ale gdy chciałem wpisać kontrolnie komendę AT nie było odpowiedzi OK. Czy to oznacza że moduł jest zepsuty czy da się zrobić coś jeszcze?

1 odpowiedź

+1 głos
odpowiedź 28 kwietnia 2016 przez użytkownika hamer_ (447)
miałem podobny problem i przy próbie łączenia zwarłem na chwile reset esp  z pinem rts lub cts konwertera uart tylko nie pamiętam ktorego po czym wgrałem aktualizacje i wszystko szło dobrze choć troche to ryzykowne a i pin chpd esp lepiej podłączyć bezpośrednio do zasilania mam dwa moduły esp jeden podstawy i jeden z większą ilością pinów i w obydwu przypadkach miałem ten sam problem jeśli wypróbujesz moją metodę robisz to na własną odpowiedzialność mi odpaliło i apki na esp działają
komentarz 29 kwietnia 2016 przez użytkownika bulbulator (3)
Ok, nie mogę powiedzieć że nie pomogłeś ponieważ program połączył się oraz wgrał program na moduł ale gdy chcę się połączyć i wysłać komendę AT wciąż nie ma odpowiedzi :/ (Odłączyłem pin GPIO0 od rezystora). Zastanawia mnie jeszcze że w arduino IDE nie mogę wybrać braku płytki by pisało "Płyta" a nie np. "płytka: arduino leonardo", nie wiem czy to może mieć jakiś związek? :)
komentarz 29 kwietnia 2016 przez użytkownika hamer_ (447)
w arduino ide musisz wybrać odpowiedni port com na którym masz moduł ewentualnie jeszcze można spróbować ze starszą wersją arduino
komentarz 30 kwietnia 2016 przez użytkownika bulbulator (3)
Niestety starsza wersja nie pomogła i wciąż nie ma odpowiedzi OK po AT ale kupię drugi moduł, może trochę droższy a nie najtańszy możliwy :)
...